fokus. die community.

User helfen Usern. Und auch wir als Entwickler sind vertreten.
In der Community zum CMS fokus können eure Themen diskutiert und Probleme gelöst werden.

// Daniel B. schrieb am 21.12.2013 um 17:49 Uhr.

#398 - Objekt nicht gefunden! Fehlermeldung

Hallo zusammen,

nach einer kleinen Pause was fokus betrifft wollte ich mal ein neues fokus installieren.
Ich hab das Paket runtergeladen und auf den Server hochgeladen. Danach alle Rechte gesetzt die für fokus nötig sind.

Sobald ich allerdings die Seite aufrufe um fokus zu installieren kommt diese Fehlermeldung:
---------------------------------
Objekt nicht gefunden!

Der angeforderte URL konnte auf dem Server nicht gefunden werden. Sofern Sie den URL manuell eingegeben haben, überprüfen Sie bitte die Schreibweise und versuchen Sie es erneut.

Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.
Error 404
localhost
Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7

---------------------------------

Ich weis nicht woran es liegt, das passiert sowohl bei einem Unterverzeichnis, Hauptverzeichnis sowie einer Sub-Domain.


Weis jemand wo der Fehler liegt?


Grüße, Daniel

fokus-Version: 3013.30

// Magnus R. ändert die Einstellungen dieses Themas:

Zuordnung von Community auf Daniel B.
Status von Neu zu In Diskussion

// Magnus R. schrieb am 09.01.2014 um 12:42 Uhr.

Hallo Daniel,

mit den Informationen kann man leider nicht viel anfangen, es scheint so als ob du deine Webseite in den falschen Ordner geladen hast oder ggf. etwas mit deiner .htaccess nicht stimmt.

Ohne weitere Informationen oder einen Zugang kann ich nicht weiter helfen.

// Daniel B. schrieb am 04.04.2014 um 17:26 Uhr an Themen-Beteiligte.

Hallo,

Entschuldigung das ich mich jetzt erst melden kann, es kam einiges dazwischen.

Der Fehler besteht immer noch, allerdings konnte ich Ihn teilweise nachvollziehen.
Ich erreiche das Verzeichnis bzw. die Subdomain wenn das Verzeichnis leer ist oder andere Inhalte drin sind.
Sobald ich aber die fokus Dateien reingeschoben habe erhalte ich die oben genannte Fehlermeldung.
In der .htaccess finde ich diesen Code der wohl dafür sorgt das ich dahin geleitet werde wo eben die Fehlermeldung erscheint ( localhost/Seiten/fokus/error/403/):


ErrorDocument 403 http://localhost/Seiten/fokus/error/403/
ErrorDocument 404 http://localhost/Seiten/fokus/error/404/
ErrorDocument 500 http://localhost/Seiten/fokus/error/500/
ErrorDocument 503 http://localhost/Seiten/fokus/error/503/

Ich weis aber nicht an was es liegt.
Alle chmod Rechte sind richtig gesetzt und wie gesagt, sobald die fokus dateien raus sind ist das Verzeichnis/die Subdomain erreichbar.
Noch zu erwähnen wäre das alles auf einem Webspace online liegt, weshalb ich es etwas komisch finde das irgendwo lokal hingeleitet werden soll und wird.


Hoffe das hilft etwas weiter.

Grüße, Daniel

// Sven B. schrieb am 09.06.2014 um 17:25 Uhr an fokus-Team.

Gerne würde ich dieses Thema nochmal aufgreifen, seit einpaar Tagen hab ich den selben Fehler, wie der Themen starter.

 

Statt der Fehlerseite kommt immer der Apache(Standard) Fehler [z.B. 404],  folgendes ist mir dabei aufgefallen.

Der Aurfuf über die URL index.php?error=404 funktioniert problem los, läuft es aber über die RewriteRule

 

RewriteRule ^error/([0-9]+)/$ index.php?error=$1

 

kommt sofort die Standard Fehlerseite. Ersetz ich aber in der RewiteRule das

^error/([0-9]+)/$ durch z.B. ^err/([0-9]+)/$

wird die "richtige" Fehlerseite angezeigt.

 

Das kann jetzt natülrich auch einfach Zufall sein, bin noch dabei mich in Fokus einzuarbeiten. Vielleich hilft diese Information aber bei der Problemlösung weiter.

 

 

 

 

// Patrick W. P. schrieb am 19.08.2014 um 15:55 Uhr an Themen-Beteiligte.

@Daniel:

Sind die zugriffsrechte richtig gesetzt? Wahrscheinlich schon, denn sonst würde es ja keinen 404 Error geben, aber prüt das doch mal.

@Sven:

hast Du es mal mit der simplen .htaccess versucht? Ist sicher nicht im Sinne der Fokuserfinder da so zu lösen, aber im Stammverzeichnis von Fokus liegt eine .htaccess Datei, vielleicht kannst Du dort den entsprechenden Link in die Errorbefehle einfügen?